For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Issues with Box Relay

Incident Report for Box

Resolved

After further monitoring, this incident is now considered resolved. Box services have been restored to full functionality. Please contact Box Support at http://support.box.com/ if you continue to experience any issues.
Posted Apr 29, 2025 - 18:13 PDT

Identified

Our team has identified the underlying cause of this issue and is working to take remediating steps. We will provide additional updates as they become available.
Posted Apr 29, 2025 - 17:18 PDT

Investigating

On 29th of April 2025 at approximately 2:36PM PST, we started investigating an ongoing issue affecting Box Relay. We will provide more information as soon as it is available.
Posted Apr 29, 2025 - 16:40 PDT
This incident affected: Box Relay.